Flask-RESTful==0.3.6 breaks unit tests
Open, HighPublic

Description

Hi,

I followed the instructions to set up the environment but for some reason 19 tests fail when I use the environment specified in requirements.txt file. However, all of them pass if I use the following requirements:

Flask==0.10.1
Flask-Login==0.2.11
Flask-RESTful==0.2.12
Flask-SQLAlchemy==2.0
Flask-WTF==0.8
Jinja2==2.7.3
Mako==1.0.1
MarkupSafe==0.23
SQLAlchemy==0.9.8
WTForms==2.0.1
Werkzeug==0.9.6
alembic==0.9.1
aniso8601==0.83
appdirs==1.4.3
arrow==0.10.0
asn1crypto==0.22.0
cffi==1.10.0
cov-core==1.14.0
coverage==3.7.1
cryptography==1.8.1
enum34==1.1.6
fedmsg==0.18.3
idna==2.5
ipaddress==1.0.18
iso8601==0.1.10
itsdangerous==0.24
kitchen==1.2.4
packaging==16.8
py==1.4.26
pycparser==2.17
pyparsing==2.2.0
pytest==2.6.4
pytest-cov==1.8.1
python-dateutil==2.6.0
python-editor==1.0.3
pytz==2014.9
pyzmq==16.0.2
requests==2.7.0
simplejson==3.6.5
six==1.10.0
wsgiref==0.1.2

yashn created this task.Jun 22 2017, 5:45 PM
kparal triaged this task as "High" priority.Jun 30 2017, 12:53 PM
kparal added a subscriber: kparal.

The problem is in Flask-RESTful==0.3.6. If you use <= 0.3.5, everything works for me. I'll prepare a patch to restrict the max version number. And somebody should figure out why that happens and whether it's something that we need to fix in our tests, or whether it's a flask-restful bug.

kparal changed the title from "Tests failing with the environment in requirements.txt" to "Flask-RESTful==0.3.6 breaks unit tests".Jun 30 2017, 12:53 PM

You can see the error log in F99608.